kostya196
01.07.2022 07:11

1. дан массив из 30 элементов, заполненный целыми случайными числами из диапазона от -15 до +50. вычислить сумму всех элементов массива, определить количество элементов массива кратных 3. исходный массив и результат подсчета(количество и сумма) вывести на экран. 2. упорядочить массив из 20 целых чисел по убыванию. исходный и массив вывести на экран. 3. составьте программу, которая по фамилии, имени и отчеству человека выводит на экран фамилию и инициалы человека. например, иванов петр степанович должно получиться на экране иванов п.с.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Юлия0981
05.10.2020 09:43
1)var

a: array [1..30] of integer;

i, s, k: integer;

begin

for i := 1 to 30 do//заполнение рандомными числами(от -15 до 50, включая и -15 и 50) массив

a[i] := random(-15, 50);

for i := 1 to 30 do//сумма элементов и подсчет кратных 3

begin

s := s + a[i];//сумма элементов

if a[i] mod 3 = 0 then//подсчет кол во кратных 3

k := k + 1;

end;

writeln('Исходный массив');

for i := 1 to 30 do

writeln('A[', i, '] = ', a[i]);

writeln('Сумма элементов массива: ', s);

writeln('Кратных 3: ', k);

end.

извини бы дальше но дела но вот подсказки:

2) метод пузырька посмотри

3) там через функцию поиска и удаления

если над у меня есть группа в вк называется просто программки если интересно можешь глянуть

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота