KoKaina
16.11.2021 14:13

Написать программу по информатики для решения : в массиве рост юношей задан отрицательным числом, рост девушек положительным, определите отдельно средний рост юношей и девушек и можно это сделать как нибудь примерно так? program xxx; var m,d,i,ran: integer; a: array [1..10] of integer; begin for i: =1 to 10 do ran: =100-random(200)+1; for i: =1 to 10 do if a[i]< 0 then m: =m+a[i] else d: =d+a[i]; write (m,' '); write (d,' ') end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
люблютебя4
05.10.2020 09:22
//Не люблю "примерно так"
//PascalABC.NET 3.2 сборка 1318

Const
  n=10;

  Var
   m,fm:real;
  mc,fmc,i:integer;
val:array[1..n] of real;
begin
for i:=1 to n do
  begin
    readln(val[i]);
    if val[i]>0 then
       begin
        inc(fmc);
        fm+=val[i];
      end
     else
     if val[i]<0 then
      begin
        inc(mc);
        m+=abs(val[i]);
      end
      else
      begin
        writeln('Funny joke!(no)');
        exit;
      end;
 end;
writeln('Male average=',m/mc);
writeln('Female average=',fm/fmc);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота