Нужно) информатика, программирование на языке паскаль. 1.введенную строку вывести в обратном порядке (с последней буквы начинается и первой заканчивается) 2.напишите программу, которая определить какой символ a или b встречается чаще.
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017 // Внимание! Если программа не работает, обновите версию!
begin var s:=ReadlnString; Writeln(s.Inverse) end.
Пример Я пишу программу на языке Паскаль ьлаксаП екызя ан уммаргорп ушип Я
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017 // Внимание! Если программа не работает, обновите версию!
begin var s:=ReadlnString('Введите строку:'); Write('Введите два символа СЛИТНО для сравнения их частоты: '); var ab:string; Readln(ab); var a:=ab[1]; var b:=ab[2]; var ka:=0; var kb:=0; for var i:=1 to s.Length do if s[i]=a then ka+=1 else if s[i]=b then kb+=1; if ka>kb then Writeln('Символ ',a,' встречается чаще, чем ',b) else if ka<kb then Writeln('Символ ',a,' встречается реже, чем ',b) else if ka<>0 then Writeln('Символы ',a,' и ',b,' встречается одинаково') else Writeln('Символы ',a,' и ',b,' отсутствуют') end.
Пример Введите строку: а роза упала на лапу азора Введите два символа СЛИТНО для сравнения их частоты: ао Символ а встречается чаще, чем о
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку