ashaburovaa
29.04.2023 13:36

Напишите программу, заполняющую массив из 45 элементов случайными числами от 0 до 34, выводящую полученный массив на экран, прозврдящую поиск элементов, делящихся на 3, подсчитывающую их количество (с выводом на экран) и считающая среднее арифметическое таких элементов

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
massenia
05.10.2020 09:09
Program n1;
const n=10;
var a: array [1..n] of integer;
i,sum,k: integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(34);
write(a[i],' ');
end;
writeln;
sum:=0;
k:=0;
for i:=1 to n do if a[i] mod 3 = 0 then
begin
k:=k+1;
sum:=sum +a[i];
end;
writeln('кол-во: ',k);
writeln('сумма: ',sum);
writeln('ср. арифм: ',sum/k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота