Войти
Регистрация
Спроси ai-bota
Privetcsfvxs
17.07.2020 22:49
Pascal, цикл while или repeat ввести число. получить другое число, путем удаления единиц, сохранив порядок следования оставшихся цифр.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
валера200331
01.04.2020 20:27
Если значение средней арифметической величины, моды и медианы не совпадают, то о чём это говорит?...
alekseymedvedev
04.10.2022 02:48
Какой паскаль используется на егэ(аbc? abc.net? или...
Evelina0889
04.10.2022 02:48
№68. количество элементов больших обоих соседей с++...
katyafedorenko1
04.01.2023 19:05
Когда пришла зима, шарик купил себе вместо валенок кроссовки. матроскин рассердился за это на шарика. а шарик на матроскина обиделся. но все же матроскину было интересно...
egoroff1271
04.01.2023 19:05
Земноводный танк может двигаться на гусеницах по суше со скоростью 70 км/ч и плавать со скоростью 10 км/ч.сколько потребуется времени этому танку,чтобы пройти общее...
илья8551
24.04.2023 20:23
Вася за 1 четверть получил по информатике 20 оценок. чтобы вычислить какую оценку он получит необходимо найти среднее арифметическое этих оценок. напишите программу...
pomorcevakata98
11.04.2023 02:58
Перевести число 13 8 в 16ричную систему счисления...
pomogyte67
25.12.2021 22:33
решить, во 2-м доп. задание...
covo1
25.12.2021 22:33
Кто кто сделать? Если бы залы и комнаты Лицея умели говорить, сколько интересного порассказали бы они... Одну из самых волнующих историй рассказала бы, конечно, так...
лена6ада
25.12.2021 22:33
Виды излучения Альфа-лучи Бета-тучи Гамма-лучи Обозначения Масса частицы Опрелелени Краткая характеристик...
Ответ:
anonimus8310
05.10.2020 08:38
//fromStudent
//без строк
var
n, nn: longint;
i : byte;
function pow (p: longint; k: byte):longint;
var j : byte;
sum : longint;
begin
sum:=1;
if k>0 then for j:=1 to k do sum:=sum*p;
pow:=sum;
end;
begin
write ('Введите число: ');
readln (n);
while n>0 do
begin
if (n mod 10)<>1 then
begin
inc (nn, pow (10, i)*(n mod 10));
inc (i);
end;
n:=n div 10;
end;
write ('Полученное число: ', nn);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота