Олиф1
19.10.2022 01:48

Напишите программу которая в последовательности целых чисел выбранных случайном образом из диапазона от 15 до 69 определяет разность максимального и минимального чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastyakotika
05.10.2020 08:11
Программа без массива:
const n=10;
var a,i,max,min:integer;
begin
Randomize;
min:=69; max:=15;
for i:=1 to n do
 begin
 a:=random(55)+15;
 write(a,' ');
 if a>max then max:=a;
 if a<min then min:=a;
 end;
writeln;
writeln('max-min = ',max,'-',min,' = ',max-min);
end.

Пример:
21 16 40 57 41 63 48 50 54 45 
max-min = 63-16 = 47

Программа с массивом:
const n=10;
var a:array[1..n] of integer;
i,max,min:integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(55)+15;
 write(a[i],' ');
 end;
writeln;
min:=a[1]; max:=a[1];
for i:=2 to n do
 begin
 if a[i]>max then max:=a[i];
 if a[i]<min then min:=a[i];
 end;
writeln('max-min = ',max,'-',min,' = ',max-min);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота