semyonshhuko9
09.11.2021 18:19

Написать программу решения квадратного уравнения ax^2+bx+c=0 в паскале, !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
DaniilEzhov036
23.05.2020 23:18

Program yravnenie;

Var
 a,b,c,D,x1,x2,p,q:Real;
Begin
 Repeat
  Write('a= ');
  Readln(a);
  if a=0 then writeln('Error: a=0. Enter another value');
 Until a<>0;
 Write('b= ');
 Readln(b);
 Write('c= ');
 Readln(c);
 p:=b/a;
 q:=c/a;
 D:=Sqr(p/2)-q;
 If D>0 then
  begin
   Writeln('x1 = ',-p/2-Sqrt(D):0:5);
   Writeln('x2 = ',-p/2+Sqrt(D):0:5);
  end
 else
 If D=0 then
  Writeln('x1 = x2 = ',-p/2:0:5)
 else
  begin
   Writeln('x1 = ',-p/2:0:5,'-i*',Sqrt(-D):0:5);
   Writeln('x2 = ',-p/2:0:5,'+i*',Sqrt(-D):0:5);
  end;
 Readln;
End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота