BazikPro
31.08.2022 11:39

Составьте программу вычисления суммы s=10+12++50

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nastyushakulik
05.10.2020 07:40
Это прогрессия с шагом d=12-10=2
1 член=10
50- последний член
an=a1+d(n-1)
50=10+2n-2
2n=42;
n=21 - в последовательности 21 член
для программы используем формулу суммы арифм. прогрессии: Sn=(a1+an)*n/2;
составляем программу:
Program n1;
const a1=10;
an=50;
n=21;
var S: real;
begin
S:=(a1+an)*n/2;
writeln(S);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота