Vikaaaa32
30.09.2020 00:21

По информатике написать программу в которой будет вычитаться из числа 1000 числа,введённые пользователем с клавиатуры до тех пор, пока разность не станет меньше 0. примечание применить цикл repeat,until буду

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
elena563
05.10.2020 07:25
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017

begin
  var t:=1000;
  var k:integer;
  repeat
    k:=ReadInteger('->');
    t-=k
  until t<0;
  Writeln('Всё...')
end.

Пример
-> 453
-> 216
-> 39
-> 64
-> 312
Всё...

Решение для "древних паскалей"

var
  k,t:integer;
begin
  t:=1000;
  repeat
    Write('->'); Read(k);
    t:=t-k
  until t<0;
  Writeln('Всё...')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота