Войти
Регистрация
Спроси ai-bota
PO3TER
29.08.2022 20:07
Требуется написать программу на c++ даны натуральные числа n и m (0≤m≥9). найти сумму первых m цифр числа n. если цифр в n меньше, чем m, то считать недостающие цифры равными 0.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
yankim14
21.07.2020 20:42
вычислите результат целочисленного деления 115//6=......
Dizelshop
25.01.2021 09:35
Дан список: football_teams = [ Manchester , Uventus , Atletico , Real , Chelsea ] пользователь вводит с клавиатуры название команды. Если в списке есть такая команда нужно удалить...
AliswandeChechir
25.12.2021 19:30
Для чого використовують майстер підстановок ....
иззи2
28.09.2022 20:17
Дано пятизначное число.найти сумму квадрата его цифр...
sashatims
06.06.2020 18:22
Переведи число 127 в десятичной в двоичную систему счисления и восьмеричную систему счисления...
AlexeyB1000
07.03.2022 22:42
R1=5 r2=10 pi=3.14 S=pi*r1*r1+pi*r2*r2 L=2*r1*r1+2*r2*r2 (Рабочим нужно s*5 кг песка, рабочим нужно L м. доски)...
Boba35
09.04.2021 10:03
Надо решить эту задачу в Паскале, напишите решение...
vintageflower
06.07.2020 10:05
Какие утверждения правильные? Ориентированный граф - это граф, ребрам которого присвоено направление Взвешенный граф - это граф, каждому ребру которого присвоен вес Ориентрованный...
Dron133
31.08.2020 05:04
Написать командный файл, который запрашивает имя пользователя, сравнивает его с заранее заданным значением и в случае совпадения выводит строку access granted и содержимое текущего...
dasha43com
20.02.2021 12:56
Дано число а (0..999999999) вывести это число в обратном порядке. пример а=12345 результат: 54321...
Ответ:
catmartovski
20.08.2020 12:29
#include <iostream>
using namespace std;
int main()
{
int n, m, n1;
int s=0;
int k=0;
cout << "n = ", cin >> n, cout << "\n";
cout << "m = ", cin >> m, cout << "\n";
n1 = n;
while (n1 > 0){
s += n1 % 10;
n1 = n1 / 10;
k++;
}
n1 = n;
for (int i=1; i<=k-m; i++) {
s -= n1 % 10;
n1 = n1 / 10;
}
cout << "s = " << s << "\n";
return 0;
}
Пример:
n = 34568
m = 4
s = 18
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота