По составить программу с дан целочисленный массив с числом элементов n и вывести из него нечетные элементы и их сумму. в паскале а если еще можно то блок схему)
Program mas; const n=4; // число элементов var a: array [1..n] of integer; //массив i, sum: integer; //переменные begin //начало sum:=0; // сумма=0 for i:=1 to n do readln(a[i]); //вводим массив for i:=1 to n do //цикл if(a[i] mod 2 <>0) then //условие нечетности begin writeln(a[i]); //выводим нечетные sum:=sum+a[i]; //считаем сумму end; writeln(sum); //выводим сумму end. //конец
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку