nadijagordijenp07vwr
07.10.2022 10:17

Составить программу расчёта произведения элементов массива; найти в нём минимальный элемент и его номер

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
пипл4
05.10.2020 06:17
Program n1;
const n=7
var a: array [1..n] of integer;
i,P,min,indMin: integer;
begin
P:=1;
for i:=1 to n do readln(a[i]);
for i:=1 to n do P:=P*a[i];
min:=a[1];
for i:= 2 to n do begin
if a[i] < min then begin
min:=a[i];
indMin:=i;
end;
end;
writeln(P);
writeln(indMin,' ',min);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота