kot291
10.11.2021 13:31

Составить программу и блок-схему для решения нижеследующих . решение каждой сопроводить пояснительной запиской с описанием используемых в конструкций языка си. y[12] вычислить среднее положительных элементов массива y yi - целые числа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Soulwax
14.08.2020 17:21
#include <stdio.h>

int main(void) {
    int Y[12];
    long int mult = 1;
    
    for (int i = 0; i < 12; i++) {
        printf("\nY[%d]=", i);
        scanf("%d", &Y[i]);
    }
    
    for (int i = 0; i < 12; i++) {
        mult *= Y[i];
    }
    
    printf("\n%f", pow(mult, 1.0/12));
    return 0;
}

Функция scanf() является процедурой ввода общего назначения, считывающей данные из пото­ка stdin. Она может считывать данные всех базовых типов и автоматически конвертировать их в нужный внутренний формат. Если бы printf() выполняла ввод, а не вывод, ее можно было бы назвать аналогом scanf().

Функция printf() записывает в stdout аргументы из списка arg-list под управлением строки, на которую указывает аргумент format.

Функция pow() возвращает значение base, возведенное в степень ехр, т. е. baseexp. Переполнение вызывает ошибку области значений. Также может возникнуть ошибка области определения.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота