titovazaiceva
22.02.2023 22:41

Составьте программу в паскале: вычислить сумм всех нечётных чисел в интервале от 1 до 2к-1. заранее огромное

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
КаМиЛлА777
26.08.2020 07:08
// PascalABC.NET 3.2, сборка 1377 от 19.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('k=');
  Writeln('s=',Range(1,2*k-1,2).Sum)
end.

Пример
k= 4
s=16
0,0(0 оценок)
Ответ:
Wwwoxanap2013
26.08.2020 07:08
Var
    k: integer; s: real;
begin
    readln(k);
    s := ((1+(2*k-1))/2)*(((2*k-1)-1)/2+1);
    writeln(s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота