sasha96679
23.06.2020 19:50

Напишите программу которая удаляет из заданного текста комбинацию "ем" (земля-планета солнечной системы)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dania7834
05.10.2020 04:24
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Replace('ем',''); s.Println
end.

Пример
> земля- планета солнечной системы
зля- планета солнечной систы
0,0(0 оценок)
Ответ:
Сережа8910
05.10.2020 04:24
// PascalABC.NET (версия 3.2, сборка 1363)

const
  RM = 'ем';
var
  c, n: char;
  seq: boolean := False;
  s: string := 'Земля - планета солнечной системы';
begin
  writeln(s);
  for var i := 1 to (length(s) -1) do
  begin
    c := s[i];
    n := s[i+1];
    if seq = True then
    begin
      seq := False;
      continue;
    end;
    if (c = RM[1]) and (n = RM[2]) then
    begin
      seq := True;
      continue;
    end
    else
    begin
      seq := False;
      write(c);
    end;
  end;
  write(s[length(s)]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота