Написать программу на pascal, используя рекурсию: дан набор символов, оканчивающихся пробелом (короче это слово), вывести символы в обратном порядке, используя рекурсию.
Var s: string; procedure PrintChar(s:string;n:integer); begin if s[n]<>' ' then begin PrintChar(s,n+1); write(s[n]); end; end; begin write('Введите слово: '); readln(s); PrintChar(s,1); end.
Program pos; var s: string; l: integer; procedure PrintChar(n: integer); var sub: string; begin sub := Copy(s, n, 1); write(sub); if n <> 1 then PrintChar(n - 1); end; begin write('Введите слово: '); readln(s); l := Length(s); PrintChar(l); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку