Мел228
14.02.2023 10:05

Составить программу на языке си известны год и номер месяца рождения человека. определить возраст человека на март(3 месяц) 2008 года

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
супербятя
05.10.2020 03:23
#include <stdio.h>

int main() {
 int year, month, cur_y = 2008, cur_m = 3, m_age, y_age;
 scanf("%d%d", &year, &month);
 if(month - cur_m > 0) {
   m_age = 12 - (month - cur_m);
   y_age = (cur_y - year) - 1;
  } else {
    m_age = cur_m - month;
    y_age = cur_y - year;
  }
  printf("%d years and %d months\n", y_age, m_age);
  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота