marijamz2016
15.10.2021 15:20

Написать программу паскаль, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла , а вывод - (в скобках указана размерность массива): 1.заменить каждый отрицательный элемент произведением всех ненулевых элементов массива (8);

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Георгий20004
26.08.2020 06:23
Const
    N = 8;

var
    a: array[1..N] of integer;
    p: integer;
    i: byte;

begin
    writeln('Введите массив из ', N, ' элементов');
    i := 0;
    p := 1;
    
    while i < n do
    begin
        i := i + 1;
        read(a[i]);
        if a[i] <> 0 then p := p * a[i];
    end;
    
    writeln('Отредактированный массив');
    i := 0;
    repeat
        i := i + 1;
        if a[i] < 0 then a[i] := p;
        write(a[i], ' ');
    until i >= n;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота