Войти
Регистрация
Спроси ai-bota
hcufiyicii
22.10.2022 21:37
3. написать программу на языке java, которая по заданному номеру единицы измерения (1 – килограмм, 2 – миллиграмм, 3 – грамм, 4 – тонна, 5 – центнер) и массы m выдавала бы соответствующее значение массы в килограммах.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
1goroh2
20.12.2022 22:37
Написать программу на паскале. создать двухмерный массив из целых чисел, в котором поменять местами максимальный и минимальный элементы. ....
mada4653
15.12.2021 08:30
Написать числа от 10 до 1 python (использовать !...
Raydi1337
05.11.2022 04:56
Напишите программу которая по исходному трёх значный му числу находит сумму квадратов цифр данного числа пример входные данные 444 выходные данные...
Sobsrhjj
19.06.2020 12:27
Побудуйте схему маршруту екскурсії та опис історичних пам яток Полтави за зразком на малюнку 8.3 (текстові та фотоматеріали міс тяться в папці Розділ 8 Пункт 8.1\Завдання...
alinkamarkova82
23.11.2022 21:34
Вывести квадраты всех двузначных чисел python (использовать ....
oroz9898
16.11.2020 03:39
Написать программу вычисления суммы кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных...
Dimo558
20.11.2020 02:29
1. В файле 17-199.txt содержится последовательность целых чисел, которые принимают значения от -10000 до 10000 включительно. Тройка идущих подряд чисел последовательности...
Йыч
03.09.2021 18:58
1) Для графического исполнителя Чертежник составьте алгоритм построения геометрической фигуры, состоящей из двух простых фигур. Повторите рисование данной фигуры три...
qwweee
17.07.2021 13:36
Виявіть культурні паралелі в прочитаних новелах...
елена1210
17.07.2021 13:36
Начертите графики следующих функций: 1) у=7 2) х=-5 3) 3х+у-2=0...
Ответ:
аомппо
05.10.2020 02:04
Import java.util.*;
public class zadacha
{
public static void main(String[]args)
{
cout("Введите номер ед.изм: ");
@SuppressWarnings("resource") Scanner cin = new Scanner (System.in);
double v=cin.nextInt();
cout("Введите массу в указанной ед.изм: ");
double m=cin.nextDouble();
if (v==1) {
print(m);
}
else if (v==2) {
print(m/st(6));
}
else if (v==3) {
print(m/st(3));
}
else if (v==4) {
print(m*st(3));
}
else if (v==5) {
print(m*st(2));
}
}
public static void cout (String text)
{
System.out.print(text);
}
public static void print(double printer)
{
System.out.print(printer);
}
public static int st(int t)
{
t=(int) Math.pow(10, t); return t;
}
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота