1анж48
12.11.2020 00:21

Напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла , а вывод – (в скобках указана размерность массива) 1. подсчитать произведение неотрицательных элементов в двухмерном массиве 6 × 3;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
larryzw17
05.10.2020 00:52
Program z1;
var
i, j, p: integer;
a: array[1..6, 1..3] of integer;
begin
p := 1;
i := 1;
j := 1;
while i <= 6 do
begin
    while j <= 3 do
    begin
        write('a[',i,'][',j,']=');
        readln(a[i,j]);
        j := j + 1;
    end;
    i := i + 1;
end;
i := 1;
j := 1;
repeat
    repeat
        if a[i,j] >= 0 then
           p := p * a[i,j];
        j := j + 1;
    until j > 3;
    i := i + 1;
until i > 6;
writeln('произведение неотрицательных элементов: ',p);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота