Вклассе 20 учеников писали диктант по языку. напишите программу и начертите к ней блок-схему, подсчитывающую количество двоек, троек, четверок и пятерок за диктант. просто , 99 за программу и блок-схему.
Блок-схема - в прилагаемом файле. Программа: const n=20; var a:array[1..20] of integer; i,k2,k3,k4,k5:integer; begin Randomize; writeln('Оценки:'); for i:=1 to n do begin a[i]:=random(4)+2; write(a[i],' '); end; writeln; k2:=0;k3:=0;k4:=0;k5:=0; for i:=1 to n do case a[i] of 2: k2:=k2+1; 3: k3:=k3+1; 4: k4:=k4+1; 5: k5:=k5+1; end; writeln('Двоек: ',k2); writeln('Троек: ',k3); writeln('Четверок: ',k4); writeln('Пятёрок: ',k5); end.