никита42728
31.03.2021 07:12

Написать программу на с#, которая будет менять в заданном в программе массиве целых чисел все элементы, которые равны указанному значению, на противоположное значению по знаку.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
морпехРФ
08.09.2020 17:02
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace zamenaZnakaVmassive
{
class Program
{
static void Main(string[] args)
{
int[] mas = new int[10];
Random r = new Random();
Console.WriteLine("Исходный массив: ");
for (int i = 0; i<mas.Length;i++)
{
mas[i] = r.Next(1, 10);
Console.Write(mas[i] + " ");
}
Console.WriteLine();
Console.WriteLine("Введите значение");
int x = int.Parse(Console.ReadLine());
Console.WriteLine("Измененный массив: ");
for (int i =0; i < mas.Length; i++)
{
if (mas[i] == x) mas[i] = mas[i] * (-1);
Console.Write(mas[i] + " ");
}
Console.ReadKey();
{
}
}
}
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота