gilev2004stepaxa
13.12.2020 17:26

Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
valeriybalybin
04.10.2020 22:01
Var
i, j, n : integer;
flag : boolean;
begin
write('n = ');
read(n);
for i := 2 to n do begin
flag := true;
for j := 2 to i-1 do
if (i mod j = 0) then begin
flag:=false;
break;
end;
if flag = true then write(i, ' ');
end;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота