кент1346
10.01.2021 19:09

Напишите программу, которая получает на вход строку типа "иван иванович иванов"(иоф), а выводит строку типа "иванов иван иванович"(фио)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tanusik32
29.05.2020 20:07

как то так чтоль

var f,i,o,iof:string;

c,probel:integer;

begin

readln(iof);

probel:=0;

for c:=1 to length(iof) do begin

if (iof[c]<>' ') and (probel=0) then i:=i+iof[c];

if (iof[c]<>' ') and (probel=1) then o:=o+iof[c];

if (iof[c]<>' ') and (probel=2) then f:=f+iof[c];

if iof[c]=' ' then inc(probel);

end;

writeln(f,' ',i,' ',o);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота