danya8202
05.08.2021 05:59

Составьте программу на языке паскаль для определения количества цифр в записи произвольного натурального числа. ( оператор while)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fmksa2006
04.10.2020 21:50
Var
  n, c: longint;
 begin
  c := 0;
  readln(n);
  while (n > 0) do
  begin
    n := n div 10;
    c := c + 1;
  end;
  write(c);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота