яяя612
04.04.2023 08:23

Кто понимает паскаль, обращаюсь к вам! нужна ваша ! составьте программу, которая выводит все символы до первого многоточия и программу, которая заменяет каждое многоточие точкой и каждый пробел точкой.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Shynar958
09.08.2020 11:48
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  var p:=Pos('...',s);
  if p>0 then Writeln(Copy(s,1,p-1))
end.

Пример
> Это такая... тестовая... строка
Это такая

// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  Writeln(s.Replace('...','.').Replace(' ','.'))
end.

Пример
> Это такая... тестовая строка, надуманная...
Это.такая..тестовая.строка,.надуманная.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота