alisaislamova2
26.02.2022 20:29

"среди чисел a,b,c,d найти сумму целых чисел " составьте программу по этой на pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
slarina171
04.10.2020 20:42
Var
  a,b,c,d:real;
  s:integer;
begin
  Write('Введите a b c d: ');  Read(a,b,c,d);
  if frac(a)=0 then s:=Trunc(a) else s:=0;
  if frac(b)=0 then s:=s+Trunc(b);
  if frac(c)=0 then s:=s+Trunc(c);
  if frac(d)=0 then s:=s+Trunc(d);
  Writeln('S=',s)
end.

Пример
Введите a b c d: 2.5 6 -3 -1.75
S=3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота