Майя123
27.04.2023 21:48

Составить программу, которая запрашивает координаты двух точек, а выводит длину отрезка, концами которого эти точки являются, и координаты середины этого отрезка. (блок систему и на языке паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
jil356
04.10.2020 20:39
Program Programma;
Uses crt;

var xA,xB,yA,yB,D: real;

Begin clrscr;
write('Введите координаты точки A через пробел: ');
readln(xA,yA);
write('Введите координаты точки B через пробел: ');
readln(xB,yB);

d:=sqrt(sqr(xA-xB)+sqr(yA-yB));
writeln;
write('Длина отрезака AB = ',d:0:3)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота