ТыСдохМнепох
11.05.2022 19:05

Составить программу по паскалю! определить количество чисел с цифрой 4 в записи числа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Link2009
04.10.2020 20:26
Var
  ar:array[1..2000] of integer;
  n,i,count:integer;
begin
  readln(n);
  for i:=1 to n do begin
    read(ar[i]);
    while ((ar[i]>0) and ((ar[i] mod 10)<>4)) do ar[i]:=ar[i] div 10;
    if ar[i] mod 10 = 4 then inc(count);
  end;
  writeln(count);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота