Составить программу: дан массив из 40, из него составить два массива, первый с четными положительными числами, а второй с остальными. рандом (-1000..1000) в паскале
Const n=40; var a,b,c:array [1..n] of integer; i,i1,i2:integer; begin randomize; for i:=1 to n do begin a[i]:=random(2001)-1000; write(a[i],' '); end; writeln; i1:=0; i2:=0; for i:=1 to n do if (a[i] mod 2 = 0)and(a[i]>0) then begin i1:=i1+1; b[i1]:=a[i]; end else begin i2:=i2+1; c[i2]:=a[i]; end; for i:=1 to i1 do write(b[i],' '); writeln; for i:=1 to i2 do write(c[i],' '); writeln; end.