dariaglaowa1
16.06.2021 04:58

Составить программу, определяющую, все целые числа из промежутка от 300 до 600, у которых сумма делителей кратна 10. язык: с++; ps: нужно решить при do_while

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
лика487
04.10.2020 19:22

#include <iostream>

using namespace std;


int main () {

    

    int digit = 300;

    

    do {

        int sum = 0;

        int teiler = 1;

        

        while (teiler <= digit)

        {

            if (digit % teiler == 0)

                sum+=teiler;

            

            teiler++;

            

        }

        

        if(sum % 10 == 0)

        {

            cout << digit << endl;

        }

        

        digit++;

        

    } while (digit <= 600);

    

    return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота