tanyushalyubim
10.11.2022 11:56

Нужна , в паскале нужно написать программу которая вводит 5 фамилий ( с клавиатуры) и выводит их в порядке возрастания

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olya12011
06.04.2022 22:17

1.Моде́ль — система, исследование которой служит средством для получения информации о другой системе; представление некоторого реального процесса, устройства или концепции.

2.Модели́рование — исследование объектов познания на их моделях; построение и изучение моделей реально существующих объектов, процессов или явлений с целью получения объяснений этих явлений, а также для предсказания явлений, интересующих исследователя.

3.Подобие, копирование

4.Натуральные модели — это реальные исследуемые системы (макеты, опытные образцы) . Имеют полную адекватность (соответствия) с системой оригиналом, но дороги. Примеры: манекен, макет автомобиля, глобус, робот , макет здания, модель малекулы,анатомический муляж.

5.Натуральные модели — это реальные исследуемые системы (макеты, опытные образцы) . Имеют полную адекватность (соответствия) с системой оригиналом, но дороги. Примеры: манекен, макет автомобиля, глобус, робот , макет здания, модель малекулы,анатомический муляж.

6. б,г

0,0(0 оценок)
Ответ:
marimitul
06.12.2020 17:49
Треугольник существует, если сумма длин двух любых его сторон больше длины третьей стороны.
Длина стороны может быть определена как расстояние между соответствующими сторонами треугольника:
\displaystyle L_{AB}=\sqrt{(x_B-x_A)^2+(y_B-y_A)^2

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
type
  Point=record
  x,y:real
  end;

procedure GetPoint(c:char;var M:Point);
begin
  Write('Введите координаты точки ',c,': ');
  Read(M.x,M.y)
end;

function Dist(a,b:Point):=sqrt(sqr(b.x-a.x)+sqr(b.y-a.y));

begin
  var A,B,C:Point;
  GetPoint('A',A); GetPoint('B',B); GetPoint('C',C);
  var ab:=Dist(A,B);
  var bc:=Dist(B,C);
  var ac:=Dist(A,C);
  if (ab<bc+ac) and (bc<ab+ac) and (ac<ab+bc) then
    Writeln('Треугольник существует')
  else Writeln('Треугольник не существует')
end.

Тестовое решение:
Введите координаты точки A: -6.9 -5.3
Введите координаты точки B: 0 11.4
Введите координаты точки C: 9 3
Треугольник существует
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота