ifanati2008
01.04.2022 18:28

(pascal)составить программу, которая определяет встречаются ли в значении строковой величины два подряд идущих одинаковых символа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
rukisha1107
04.10.2020 17:49
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('->');
  var c:=s[1];
  for var i:=2 to s.Length do
    if s[i]=c then begin Writeln(c,' - повторяющийся символ'); exit end
    else c:=s[i];
  Writeln('Повторяющихся символов нет')
end.

Пример
-> переезд
е - повторяющийся символ
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота