1) напишите программу в паскале заполнить массив случайными целыми числами. заменить элементы массива, кратные k нулями, остальные 1 ( к ввести с клавиатуры)
var mas: array[-1000..1000] of integer; i, k, n: integer;
begin {ввод количества элементов массива} readln(n); {ввод числа к} readln(k); {ввод массива и его вывод на экран} randomize; for i := 1 to n do begin mas[i] := 50 - random(100) - 1; write(mas[i]:4); if (i mod 10 = 0) then writeln; end; {замена элементов массива} writeln; for i:=1 to n do begin if (mas[i] mod k=0) then mas[i]:=0 else mas[i]:=1; write (mas[i]:4); if (i mod 10 = 0) then writeln; end; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку