akolosov2002
14.09.2021 01:20

Напишите программу, которая для последовательности натуральных чисел находит среднее арифметическое. программа получает на вход числа, кол-во чисел неизвестно, последовательность заканчивается числом 0 (0 в последовательность не входит)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Radmir5689
04.10.2020 17:09
Var
  a: array[1..1000] of integer;
  sa: real;
  i: byte;
begin
  writeln ('Введите числа: ');
  i:=0;
  sa:=0;
  repeat
    i:=i+1;
    read (a[i]);
    sa:=sa+a[i];
  until a[i]=0;
  sa:=sa/(i-1);
  writeln ('Среднее арифметическое чисел = ',sa);
end.

Пример:
Введите числа: 
2 4 2 4 2 4 0 
Среднее арифметическое чисел = 3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота