маша3053
14.05.2020 05:13

Составьте программу,которая выполняет массив а(1..10) случайными целыми числами в диапазоне от 1 до 10,затем меняет местами первый элемент со вторым,третий с четвертым и т.д. выведите на экран исходный и полученный массивы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zlataaug
04.10.2020 16:18
Program swap;
const
  N = 10;
var
  a: array [1..N] of integer;
  i, temp: integer;
begin
  randomize;
  writeln('исходный массив: ');
  for i := 1 to N do
    begin
      a[i] := Random(10);
      write(a[i], ' ');
    end;
  writeln;
  i := 1;
  while i <= 9 do
    begin
      temp := a[i];
      a[i] := a[i+1];
      a[i+1] := temp;
      i := i + 2;
    end;
  writeln('полученный массив: ');
  for i := 1 to N do
      write(a[i], ' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота