leomessi171
15.11.2020 01:34

Написать программу на pascal "дана строка символов s, состоящая максимум из 250 символов. напишите программу, которая проверит является ли строка s палиндромом. примеры палиндромов: ‘cojoc’, ‘cazac’, ‘potop’, ‘rotor’."

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Zlyka11
04.10.2020 16:15
Var
s:string;
l,i:byte;
begin
readln(s);
l := length(s);
for i:= 1 to l div 2 do begin
if s[i] <> s[l-i+1] then begin
writeln('NO');
halt;
end;
end;
writeln('YES');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота