Dildora13
28.08.2022 19:04

Напишите программу, которая определяет, является ли заданная строка правильным ip-адресом. на паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sarah205681
04.10.2020 15:58
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadlnString('IP=').ToWords('.');
  if a.Length<>4 then
    Writeln('Адрес - это четыре числа, разделенные точками')
  else begin
    var n:integer;
    foreach var c in a do begin
      if not TryStrToInt(c,n) then begin
        Writeln(c,'- не целое число'); exit end
      else
        if n>255 then begin Writeln(c,' превышает 255'); exit end;
      end;
    Writeln('IP-адрес корректен')  
    end
end.

Примеры
IP= 128.16.35.a4
a4- не целое число

IP= 240.127.56.340
340 превышает 255

IP= 34.56.42,5
Адрес - это четыре числа, разделенные точками

IP= 128.0.0.255
IP-адрес корректен
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота