Alikhan666
15.01.2022 17:46

60 написать программу, в которой бы с клавиатуры пользователь вводил четыре числа (тип данных real). после этого программа выводила бы на экран номер наибольшего из них. нумерация начинается с 1 без использования массивов

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ginfv
29.05.2020 16:09

Язык С++

#include <iostream>

int main() {

double a, b, c, d;

std::cin >> a >> b >> c >> d;

if (a > b && a > c && a > d) {

 std::cout << 1;

}

else if (b > a && b > c && c > d) {

 std::cout << 2;

}

else if (c > a && c > b && c > d) {

 std::cout << 3;

}

else {

 std::cout << 4;

}

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота