Svetik15102011
18.04.2023 22:04

Лёгкая по паскалю! составьте программу, которая позволяет заменить в строке s слово t1 на слово t2. строку s и слова t1 и t2 введите с клавиатуры. пример ввода: на небе появилась туча. туча луна пример вывода: на небе появилась луна.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Варя11011
04.10.2020 15:34
Var
  s, t1, t2, st: string;
  i: integer;
begin
  readln(s);
  readln(t1);
  readln(t2);
  if pos(t1, s) <> 0 then
    i := pos(t1, s);
  st := copy(s, 1, i - 1);
  st := st + t2;
  st := st + copy(s, i + length(t1), length(s));
  writeln(st);
  readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота