BobrLite
26.01.2021 02:15

Синформатикой, ! 98 ! тема: массивы. нужно написать программу в паскале. 1) сформируйте одномерный массив из 4 элементов (значения элементов укажет пользователь с клавиатуры). обнулите значения всех элементов с четными индексами. выведите значения одномерного массива в строку через пробел. 2) сформируйте одномерный массив и n-элементов (значения элементов зависит от порядкового номера массива и вычисляется по формуле ((i+3)/2). параметр n должен задавать пользователь. напишите программу, вычисляющую сумму значений элементов одномерного массива и среднее арифметическое введенных n-чисел. вывод оформите в строку через пробел. 3) в произвольно заданном одномерном массиве (случайные значения из отрезка от -7 до 14) из 11 элементов определить минимальный элемент и его номер. 4) поменять местами значения первого и пятого элементов в одномерном массиве. вывести на экран исходный массив, заданный пользователем любым и преобразованный массив. заранее большое !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
taniaselikova
17.04.2021 17:57
Const
  MAX_SIZE = 10;
 
var
  a: array[1..MAX_SIZE] of integer;
  i, size: integer;
 
procedure delete_odd_elements();
var i, j: integer;
begin
  i := 1;
  repeat
    if odd(a[i]) then
    begin
      dec(size);
      for j := i to size do
        a[j] := a[j + 1]
    end
    else inc(i);
  until i > size;
end;
 
begin
  writeln('Исходный массив: ');
  size := MAX_SIZE;
  for i := 1 to size do
  begin
    a[i] := random(100);
    write(a[i] : 3);
  end;
  delete_odd_elements;
  writeln;
  writeln('Полученный массив: ');
  for i := 1 to size do
    write(a[i] : 3);
end.
0,0(0 оценок)
Ответ:
nakoreshoy50qg
22.07.2021 14:34

program sorting;

const

 N = 10;

var

 v: array[1..N] of integer;

 d: integer;

 i, t: integer;  

 k: boolean;  

begin

 randomize;

 write('ДО сортировки:    ');

 for i := 1 to N do

 begin

   readln(v[i])

   write(v[i]:6);

 end;

}  

 d := N div 2;

 while(d > 0) do

 begin

   k := true;  

   while k do

   begin

     k := false;

     i := 1;

     for i := 1 to N - d do

     begin

       if(v[i] > v[i + d]) then

       begin

         t := v[i];

         v[i] := v[i + d];

         v[i + d] := t;

         k := true;

       end;

     end;

   end;    

   d := d div 2;

 end;

 writeln;

 write('ПОСЛЕ сортировки: ');

 for i := 1 to N do

   write(v[i]:6);

 writeln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота