хомяк2005
24.04.2023 16:15

Информатика python. написать программу 1. запросить пользователя ввести имя файла(файл содержит числа) если файл не существует - выдать ошибку,завершить программу 2. создать пустой список.прочитать файл.удалить \n значения.перевести все в вид integer. присоеденить форматированный файл к списку. если в строчке нет числа - пропустить и читать следующую строчку выписать наибольшее число списка.либо выдать ошибку о пустом списке. файл сохранить в формат csv. таким образом : (число; число - наибольшее значение списка)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
suri4
16.01.2020 13:44
ответ: 1) Розрізняють такі друковані видання: книги, журнали, брошури, газети, буклети, листівки тощо. Кожне з них має своє призначення, автора матеріалу й відповідно — певну структуру, формат видання та правила розповсюдження. Електронними публікаціями називають розповсюдження відомостей за до електронних носіїв, таких як диски чи флеш-накопичувачі, або за до Інтернету. 2) Підготовка публікації — комплексний процес, який складається з таких етапів: - набору тексту; - редагування тексту; - коригування тексту; - підготовки зображень; - розробки дизайну; - верстки видання. До мінімальної конфігурації настільної видавничої системи мають входити пристрої: - введення; - збереження; - опрацювання; - виведення; - передавання. 3) Програмні засоби для створення публікацій: Adobe InDesign; Adobe PageMaker; Frame Maker; LaTeX (для текстів зі складними математичними формулами); Microsoft Publisher; PagePlus; QuarkXPress; Scribus. 4) Елементи публікації: текстові блоки (поля, написи) — контейнери для тексту; блоки зображення — контейнери зображень растрової чи векторної графіки; елементи оформлення документа — векторні об'єкти, використовувані для оформлення комп'ютерної публікації (у тому числі візерунки). 5) Не знаю но что-то есть. Створюючи нову публікацію, бажано заздалегідь визначити, якою вона має бути. Тоді відразу після завантаження програми можна обрати шаблон, що відповідає потрібному типу публікації. Після запуску програми відображається меню Файл з обраною вказівкою Створити.
0,0(0 оценок)
Ответ:
Xkdidid
26.08.2021 01:41

Відповідь:

#include<stdio.h>

#include<stdlib.h>

int quantity(){

int y;

while(1){

printf("Введите количество элементов:\n");

if(!(scanf("%i",&y))||y<=0){

printf("Неккоректный ввод. Повторите\n");

fflush(stdin);}

else return y;}

       

}

float middle_arif(int quantity){

   float f,sum=0;

   int temp;

for(temp=0;temp<quantity;temp++){

 while(1){

printf("Введите %i элемент:\n",temp+1);

if(!(scanf("%f",&f))||f<0||f>100){

printf("Неккоректный ввод. Повторите\n");

fflush(stdin);

}

else{

 sum+=f;

 fflush(stdin);

 break;

}

        }}

   return sum/quantity;}

int main(){

setlocale(0,"");

printf("Среднее арифметическое значений равно %f",middle_arif(quantity()));

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота