viliam3486
22.11.2022 15:42

Составьте программу, которая заполняет массив а 1..0 случайными целыми числами в диапазоне от 1 до 10 и вычесляет сумму элементов массива с четными значениями

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ангелок2007
04.10.2020 12:58
Program ex;

const
g = 100;

var
a, i, sum: integer;
b: array[1..g] of integer; // Не совсем понятен был размер массива. Мною было принято решение задать значение 100. Вы можете изменить его в любое время.
// Поменяв значение в константе g.
begin
sum := 0;
for i := 1 to g do 
begin
a := random(1, 10);
b[i] := a;
if b[i] mod 2 = 0 then
sum := b[i] + sum;
end;
write('Сумма массивов с четными значениями: ', sum)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота