Войти
Регистрация
Спроси ai-bota
Aynur123455
08.08.2022 15:34
Напишите программу, находящую сумму арифметической прогрессии по заданным значениям первого элемента, разности и количества элементов последовательности.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
victoriabetenecova
11.04.2023 08:48
нужно Спроектировать сенсорную сеть на 77 устройств по технологии ZigBee...
ilia39loh
29.10.2022 22:12
2. Қазақстанда авторлар құқығын қорғайтын ұйым бар?...
ЧерепашкаВася
24.04.2020 14:13
Закончи предложение любое сочетание оказываемое напечатанное написанное или существующее в одной форме называется 1 фраза 2 слова 3 текст 4 диалог...
лилия253
04.08.2022 10:41
Для решения этой задачи Вам необходимо написать программу на одном из языков программирования.Школьники Ваня и Паша занимаются в кружке робототехники. На одном из занятий они...
fnabtr4ui26986
28.01.2023 21:39
. В ходе повседневной жизни каждый из нас получает (воспринимает) самую разнообразную информацию. Так что же такое информация (наиболее полный ответ)? ...
mrrosslanp0aahw
07.11.2020 10:54
В таблице БД три столбца: Фамилия , Имя , Отчество . Записаны 200 человек. Сколько полей и записей в таблице...
mmedvedev389
29.10.2021 20:11
РЕШИТЕ ЗАДАЧУ ПО ИНФОРМАТИКЕ!! Дано:Скорость= 128000б/сI=375к/бНайти: t=?...
zanna74
13.01.2020 21:54
Передаваемая информация может поступать от источника к приемнику с условных знаков или сигналов, то есть в закодированном виде. Что понимают под кодированием информации? 1)это...
verenikinaulia
16.04.2022 22:26
Даной число 10011011₂ в восьмиразрядном представлении со знаком. Запишите это число в десятичной системе счисления. (в ответе запишите только число без указания основания системы)...
нрррлртптп
13.10.2020 07:02
Заполните массив с клавиатуры целыми числами. определите, есть ли в данном массиве положительные элементы, кратные числу a заданному с клавиатуры? если есть, то вывести слово...
Ответ:
puh9999
04.10.2020 12:26
1. Вспомним формулу для нахождения суммы арифметической прогрессии:
Где а - это первый элемент последовательности
n - количество элементов
d -разность.
Составим программу на языке СИ
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int a,n,d;
double y;
int main(void)
{
printf("a=");
scanf("%d", &a);
printf("n=");
scanf("%d", &n);
printf("d=");
scanf("%d", &d);
y=((2*a+(n-1)*d)/2.0)*n;
printf("%lf", y);
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота