guchsuqa
27.06.2022 18:29

Напишите программу в паскалеabc, выводящую n-ую цифру в последовательности натуральных чисел : вводится число n до 100 при решении этой нельзя использовать любой из видов условной инструкции if. вывести надо только ответ

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mishchenko07
04.10.2020 12:03
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var n:=ReadInteger('n=');
  Writeln(1.To((n+10) div 2).JoinIntoString('')[n]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота