sludkov
05.04.2020 00:48

Напишите программу подсчета количества и суммы нечетных элементов массива

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
EinLegoMan
04.10.2020 10:26
Код Pascal1 2 3 4 5 6 7 8 9 10 11 12 begin   var Size := ReadLnInteger('Размер массива =');   var A : array of Integer; SetLength(A, Size);   for var i := 0 to pred(Size) do     A[i] := ReadLnInteger('A[' + (i+1).ToString + '] =');   WriteLn('Введён массив A = ', A);   var count := 0; for var i := 0 to pred(Size) do if Not odd(A[i]) then count += 1;   WriteLn('В массиве чётных элементов: ', count);   var max := 0; for var i := 1 to pred(Size) do if A[max] < A[i] then max := i;   var k := ReadLnInteger('k = '); A[max] *= k;   WriteLn('Массив A = ', A); end.
0,0(0 оценок)
Ответ:
Alchimick
04.10.2020 10:26
Если что нибудь нужно пояснить или изменить, пиши.
const n=10;  //вместо 10 количество ячеек в массиве (любое)
var a: array [1..n] of integer;
i,k,s: integer;
begin
randomize;
for i:=1 to n do begin
a[i]:=random(100);
  if i mod 2<>0 then
     begin k:=k+1; s:=s+a[i]; end; end; 
writeln(k,'  ',S) 
 end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота