zlatoslava2p08lf0
09.05.2022 13:59

Необходима программа на языке паскаль в классе проведено тестирование. максимально можно было набрать 100 . известны , набранные каждым из учеников. определите, сколько учеников в классе набрали: , отклоняющиеся от среднего значения не более чем на 10%.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
flagmarta
04.10.2020 10:13
Var a:array[1..100] of real;
i,k,n:integer;
sr,pr,s:real;
begin
write('Введите кол-во учеников в классе: '); readln(n);
writeln('Введите учеников: ');
for i:=1 to n do
read(a[i]);

s:=0;
for i:=1 to n do
s:=s+a[i];
sr:=s/n; pr:=sr/10;
for i:=1 to n do
if (a[i]<sr+pr) and (a[i]>sr-pr) then
inc(k);
writeln('Кол-во , отклоняющиеся от срзнач. не более чем на 10%: ',k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота