Вкаждом шкафу 9 полок, на каждой полке по 4 книги. напишите программу, определяющую, в каком по номеру шкафу и на какой полке находится n-я книга. паскаль
Если шкафы и полки нумеровать с 1, то можно так: var n,a,b:integer; begin write('n = '); readln(n); a:=(n-1) div (9*4)+1; b:=(n-(a-1)*9*4-1) div 4+1; writeln('Шкаф = ',a,' полка = ',b); end.
Пример: n = 57 Шкаф = 2 полка = 6
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку