dragonhar
26.03.2022 14:40

Написать программу, выводящую на экран таблицу квадратов четных чисел от 0 до 10 в убывающем порядке: 100, 81, составь блок-схему алгоритма, и напиши программу которая выводит на экране узор, состоящий из звездочек. должно быть 20 строчек со звездочками так, чтобы в каждой последующей строке было на одну звездочку больше. для вывода на экран строки, со- держащей n звездочек, используй команды string repeatedstring = new string('*', n); console.write (repeatedstring); microsoft visual studio c#

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kgatikha1
08.09.2020 12:11
Using System;
// Написать программу, выводящую на экран таблицу квадратов
// четных чисел от 0 до 10 в убывающем порядке: 100, 81, 49...
// Составь блок-схему алгоритма, и напиши программу которая
// выводит на экране узор, состоящий из звездочек. Должно быть 20 строчек со звездочками так, чтобы в каждой последующей строке было на одну звездочку больше. Для вывода на экран строки, со- держащей N звездочек, используй команды
// String repeatedString = new String('*', N); Console.Write (repeatedString);
// Microsoft visual studio c#

namespace NoNamespace {
    internal class Program {

        private static void Main() {
            SquaresOfNumbersDesc();
            Stars(20, 10);
            Console.ReadLine();
        }

        private static void SquaresOfNumbersDesc() {
            Console.WriteLine();
            for (var i = 10; i >= 0; i = i - 2) {
                Console.Write("{0} ", i * i);
            }
            Console.WriteLine();
        }

        private static void Stars(int n, int start_stars) {
            Console.WriteLine();
            for (var i = 0; i < n; i++) {
                Console.WriteLine(new String('*', start_stars + i));
            }
            Console.WriteLine();
        }
    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота