SmartPocan
04.03.2021 23:39

А)составить программу, которая увеличивает в 10 раз все элементы массива. б) заменяет все отрицательные элементы их индексами. сделать нужно и а и б. через паскаль надо.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mawa18
04.10.2020 09:51
//PascalABC.NET 3.2 сборка 1318

//а

begin
  writeln('Введите размерность:');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  ar.Transform(x -> x*10);
  ar.Print;
end.

//б

begin
  writeln('Введите размерность');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  for var i:=0 to n-1 do            //индексация с 0
    if ar[i]<0 then ar[i]:=i;
  ar.Print;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота